?? 炉石湮灭者祖拉玛特:SL主圖 (源碼 主圖 通?- 祖拉的世界|上古卷轴阿祖拉被口爆

SL主圖 (源碼 主圖 通達信)

{兩線}

XA_1:=120;

XA_2:=MA(CLOSE,XA_1);

XA_3:=POW(CLOSE-XA_2,2);

XA_4:=MA(XA_3,XA_1);

XA_5:=SQRT(XA_4);

XA_6:=XA_2+2*XA_5;

一突:REF(XA_2,1),COLORYELLOW,LINETHICK1;

二突:REF(XA_6,1),COLORFF00FF,LINETHICK1;

{K線顏色+跳空}

C3:=REF(C,1);

漲停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0);

STICKLINE(漲停,OPEN,CLOSE,2,0),COLORYELLOW;

STICKLINE(漲停,H,L,0,0),,COLORYELLOW;

跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);

STICKLINE(跌停,OPEN,CLOSE,3,0),COLORGREEN;

STICKLINE(跌停,H,L,0,1),COLORGREEN;N:=10;

UP:=(C/REF(C,1)>1.05 AND NOT(C/REF(C,1)>1.095));

STICKLINE(UP,OPEN,CLOSE,2,0),,COLORLIRED;

STICKLINE(UP,H,L,0,0),COLORLIRED;

DOWN:=(C/REF(C,1)<0.95 AND NOT(C/REF(C,1)<0.907));

STICKLINE(DOWN,OPEN,CLOSE,3,0),COLORFF6600;

STICKLINE(DOWN,H,L,0,1),COLORFF6600;

向下跳空:=HIGH<REF(LOW,1);

STICKLINE(向下跳空,HIGH,REF(LOW,1),4,0),COLOR888888;

向上跳空:=LOW>REF(HIGH,1);

STICKLINE(向上跳空,LOW,REF(HIGH,1),4,0),COLOR888888;

MA5:MA(CLOSE,5),NODRAW;

AA1E:=AMOUNT/V;

BB1E:=L<AA1E*0.9;

CC1E:=(C-REF(C,1))/REF(C,1)*100>1.2;

DD1E:=L<MA(C,5)*0.921;

EE1E:=V<MA(V,5)*1.5;

異動:=BB1E AND CC1E AND DD1E AND EE1E,LINETHICK0;

DRAWTEXT(異動,(LOW* 0.98),"異動"),COLOR40CCFF;

{強勢殺入 參數: N 1 20 10 ZF 1 10 5}

BDGD:=C=HHV(C,N);

GDSJ:=BARSLAST(BDGD);

底:LLV(L,N),COLORFF9933,LINETHICK1,CROSSDOT,NODRAW;

頂:HHV(H,N),COLOR0099CC,LINETHICK1,CROSSDOT,NODRAW;

前高:IF(GDSJ>0,REF(C,GDSJ),REF(C,GDSJ)),COLORFFFF00,POINTDOT,LINETHICK2,NODRAW;

MA5S:MA(C,5),LINETHICK2,COLORFF00FF,NODRAW;

MA13S:MA(C,13),LINETHICK2,COLOR00FF00,NODRAW;

MA20S:=MA(C,20);

MA30S:=MA(C,30);

MA60S:=MA(C,60);

MA120S:=SMA(C,120,1);

TP:=CROSS(C,REF(前高,1));

出擊:=TP AND COUNT(TP,5)=1;

TPSJ:=BARSLAST(出擊);

HC:=CROSS(REF(前高,TPSJ+1),L) OR CROSS(REF(前高,TPSJ),C);

回踩:=HC AND TPSJ>1;

放量上漲:=CLOSE/REF(CLOSE,1)>=1.01 AND VOL/REF(VOL,1)>=1.5 AND VOL>MA(VOL,5) AND REF(VOL,1)/REF(MA(VOL,5),1)<=1.8;

箱體形成:=((HHV(C,3)/LLV(C,N)-1)*100<=ZF AND (HHV(C,N)/LLV(C,3)-1)*100<=ZF)*0.3;

接近箱頂:=(CLOSE/REF(HHV(CLOSE,N),2)<=1.02 AND HIGH/REF(HHV(CLOSE,N),2)>=0.98)*0.5;

P1:=BARSLAST(箱體形成);

P2:=BARSLAST(接近箱頂);

期待突破:=(放量上漲 AND 接近箱頂 AND P1<=3 AND P2<=1)*2;

關注:=(放量上漲 AND 接近箱頂)*1;

ZH520:=ABS(MA5S-MA20S)/MA20S*100<=N;

ZH530:=ABS(MA5S-MA30S)/MA30S*100<=N;

QSXS1:=MA5>REF(MA5S,1);

QSXS2:=MA20S>REF(MA20S,1);

QSXS3:=MA30S>REF(MA30S,1);

DTPL:=MA20S>MA30S AND MA30S>MA120S;

LYHT:=DTPL AND QSXS2 AND QSXS3 AND NOT(QSXS1) AND REF(QSXS1,1);

老鴨回頭:=LYHT*50;

WR5:=100*(HHV(H,5)-C)/(HHV(H,5)-LLV(L,5));

WR6:=100*(HHV(H,6)-C)/(HHV(H,6)-LLV(L,6));

WR:=80-(WR5*3+WR6*2)/5;

坑:=IF(WR<0,WR,0);

LYT:=DTPL AND QSXS2 AND QSXS3 AND COUNT(QSXS1,4)<=1;

GJHS:=C>MA5 AND ((QSXS1 AND NOT(REF(QSXS1,1))) OR C>REF(C,3));

LYKK:=GJHS AND (ZH520 OR ZH530) AND LYT;

DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);

買:=(LYKK AND NOT(REF(LYKK,1)))*50;

買1:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);

賣1:=IF(HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX),1,0);

VARC:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;

VAR6S:=REF(C,1);

VAR7:=SMA(MAX(C-VAR6S,0),6,1)/SMA(ABS(C-VAR6S),6,1)*100;

優選:=(買 AND COUNT((MA13S>MA20S),5)=5)*100;

{以下設置主圖顯示方式}

{DRAWTEXT(老鴨回頭,(MA13+MA20)/2, "○");

DRAWTEXT(WR<0,L*0.99, "#"),COLORYELLOW;

DRAWTEXT(WR<-10,L*0.99, "#"),COLORWHITE;

STICKLINE(買,H,L,1,0),COLOR00FF00,LINETHICK2;

STICKLINE(買,O,C,3,1),COLOR00FF00,LINETHICK2;}

DRAWTEXT(買>0,L*0.99, "▲B"),COLORRED;

DRAWICON(CROSS(82,VARC),HIGH,39);

DRAWTEXT(CROSS(84,VAR7),H*1.01,"頂"),COLORFFFF00;

DRAWTEXT(FILTER(賣1=1,5),HIGH*1.025,"▼賣"),COLOR00FF00;

DRAWTEXT(出擊,L*0.99,"強 "),COLORYELLOW;

{小虛線}

NS:=8;

AA:=REF(H,NS)=HHV(H,2*NS+1);

AA1:=REF(L,NS)=LLV(L,2*NS+1);

QY:=BACKSET(AA,NS+1);

QY1:=BACKSET(AA1,NS+1);

CC:=FILTER(QY,NS) AND H=HHV(H,NS+1);

CC1:=FILTER(QY1,NS) AND L=LLV(L,NS+1);

DDD:=BARSLAST(CC);

DD2:=BARSLAST(CC1);

GDTS:=IF(CC,CURRBARSCOUNT,0);

DDTS:=IF(CC1,CURRBARSCOUNT,0);

DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);

DDTS1:=IF(DD2,REF(DDTS,DD2),DDTS);

GDCS1:=CONST(DINGBUTS);

DDCS1:=CONST(DDTS1);

GDCS13:=CONST(REF(HIGH,GDCS1-1));

DDCS13:=CONST(REF(L,DDCS1-1));

DINGBUTS1:=REF(DINGBUTS,DDD+1);

DDTS2:=REF(DDTS1,DD2+1);

GDCS2:=CONST(DINGBUTS1);

DDCS2:=CONST(DDTS2);GDCS23:=CONST(REF(HIGH,DINGBUTS1-1));

DDCS23:=CONST(REF(L,DDTS2-1));

XG1:=BACKSET(ISLASTBAR,GDCS1);

XD1:=BACKSET(ISLASTBAR,DDCS1);

XG2:=BACKSET(ISLASTBAR,DINGBUTS1);

XD2:=BACKSET(ISLASTBAR,DDTS2);

STICKLINE(XG2,GDCS23,GDCS23,2,0),COLORWHITE;

STICKLINE(XG1,GDCS13,GDCS13,2,0),COLORYELLOW;

STICKLINE(XD2,DDCS23,DDCS23,2,0),COLORGRAY;

STICKLINE(XD1,DDCS13,DDCS13,2,0),COLORCYAN;

{KDJ測頂底}

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

{文字:}

DRAWTEXT(CROSS(100,J),H*1.02,"▼風險"),COLORGREEN;

DRAWTEXT(CROSS(J,0),L*0.97,"▲關注"),COLORWHITE;

{變盤}

DRAWTEXT(REF(DMI.ADX,1)>50 AND CROSS(REF(DMI.ADX,1),DMI.ADX),H*1.01,"↙變盤"),COLORMAGENTA;

{行業信息}

Z1:=STRCAT(HYBLOCK," ");

Z2:=STRCAT(Z1,DYBLOCK);

Z3:=STRCAT(Z2," ");

DRAWTEXT_FIX(ISLASTBAR,0,0.16,0,STRCAT(Z3,GNBLOCK)),COLORLIRED;

DRAWTEXT_FIX(ISLASTBAR,0,0.12,0,EXTERNSTR(0,3)),COLORWHITE;

DRAWTEXT_FIX(ISLASTBAR,0,0.06,0,EXTERNSTR(0,6)),COLORLIBLUE;

DRAWTEXT_FIX(ISLASTBAR,0,0.03,0,EXTERNSTR(0,12)),COLORLIGREEN;{老王}

DRAWTEXT_FIX(ISLASTBAR,0,0.09,0,FGBLOCK),COLORLIMAGENTA;

DRAWTEXT_FIX(ISLASTBAR,0,0.0,0,EXTERNSTR(0,1)),COLORYELLOW;{融勝}

{穩漲}

紅軌道:=MA(MA(CLOSE,3),1),LINETHICK1,COLORYELLOW;

軌道:MA(MA(CLOSE,3),3),COLOR32CD32,LINETHICK1;

NOTEXT_升:IF(紅軌道>=軌道,軌道,DRAWNULL),COLORRED,LINETHICK1;

機構:(L2_VOL(0,0) - L2_VOL(0,1))*10000/FINANCE(7),NODRAW,COLORRED;

大戶:(L2_VOL(1,0) - L2_VOL(1,1))*10000/FINANCE(7),NODRAW,COLORMAGENTA;

主力:機構+大戶,NODRAW,COLORYELLOW;

累計:=SUM(主力,30),COLORMAGENTA;

均值:=EMA(累計,MIN(10,30)),COLORWHITE;

{一絕}

Q_1:=C-REF(C,1);

Q_2:=100*EMA(EMA(Q_1,6),6)/EMA(EMA(ABS(Q_1),6),6);

Q_3:=CROSS(EMA(C,19),EMA(C,7));

Q_4:=CROSS(EMA(C,7),EMA(C,19));

ZD1:=L=LLV(L,BARSLAST(Q_3)+1);

ZD2:=LLV(L,BARSLAST(Q_3)+1);

ZD3:=H=HHV(H,BARSLAST(Q_4)+1);

ZD4:=HHV(H,BARSLAST(Q_4)+1);

Q_A:=DRAWLINE(ZD1,ZD2,ZD3,ZD4,0);

U1:=H=HHV(H,BARSLAST(Q_4)+1);

U2:=HHV(H,BARSLAST(Q_4)+1);

U3:=L=LLV(L,BARSLAST(Q_3)+1);

U4:=LLV(L,BARSLAST(Q_3)+1);

Q_B:=DRAWLINE(U1,U2,U3,U4,0);

TJ:=IF(Q_B<REF(Q_B,1) AND Q_B=Q_A,1,0);

BB:=REF(TJ,1)=0 AND TJ>=1 ;

DRAWICON(BB,L*0.998,38);

SS:=REF(Q_A<REF(Q_A,1) AND Q_B=Q_A,1)=0 AND TJ<1;

DRAWICON(SS,H*1.002,39);

{私募公式}

AAE:= WINNER(CLOSE+CLOSE*15/100)*100;

BBE:= WINNER(CLOSE+CLOSE*0/100)*100;

CCE:= AAE-BBE;

DDE:= (WINNER(CLOSE-CLOSE*0.1/100)-WINNER(CLOSE-CLOSE*15/100))*100;

EEE:= CCE<3 ANDDDE<0.5 AND OPEN>LOW;

AE1:= DYNAINFO(6);

AE2:= IF(LOW>AE1,0,IF(HIGH<AE1,1,(AE1-LOW+0.01)/(HIGH-LOW+0.01)));

AE3:= VOL/WINNER(LOW);

AE4:= REF(HHV(CLOSE,120),1);

AE5:= REF(LLV(CLOSE,120),1);

AE6:= 100*(CLOSE-AE5)/(AE4-AE5);

AE7:= AE2>0 OR AE2=1;

AE8:= AE7 AND AE3/REF(AE3,3)>=3 AND AE6<80;

AE9:= REF(AE8,1) OR REF(AE8,2) OR REF(AE8,3) OR REF(AE8,4);

AE10:= AE8 AND AE9;

AE11:= IF(FILTER(AE8,3),5,0);

AE12:= FILTER(IF(FILTER(AE10,3) OR EEE,10,0),3);

DRAWICON(AE12,L-0.0018,5);

A2:=REF(MA(C,20),1);J1:=(MA(C,20)-A2)/A2*100;MJ1:=MA(J1,3);

乖離2:=(MA(C,20)-MA(C,30))/MA(C,30)*100;

VAC1:=IF(BETWEEN(乖離2,-2,5),2,0);

XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));

XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);

XL3:=CROSS(XL2,(0 - 20));

DRAWTEXT(FILTER(((XL1 > 0) AND LOW),5),(LOW - 0.0014),"●買點");

DRAWTEXT((XL3 > 0),(LOW - 0.0011),"●絕對底部")COLORYELLOW;

X6:=REF(CLOSE,1);

X7:=((SMA(MAX((CLOSE - X6),0),7,1) / SMA(ABS((CLOSE - X6)),7,1)) * 100);

X8:=CROSS(79,X7);

X9:=FILTER(X8,4);

DRAWTEXT(X9,(HIGH * 0.9989),"-●出貨"),COLORGREEN;

{金牛啟動}

年:=MA(CLOSE,240);

漲幅%:=(C-REF(C,1))/REF(C,1)*100;

RSVV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;

VARB2:=(RSVV/2+22)*1;

量:=EMA(VOL,13);

資金:=EMA(AMOUNT,13);

過濾:=((資金 /量) / 100);

提純:=(((CLOSE -過濾) / 過濾) * 100);

黃金:=((提純 < (0)) AND ZXNH);

DRAWTEXT(買>0,L-0.0013,"-牛"),COLORFFFFFF;

DRAWTEXT(買>0,L-0.0018,"▲"),COLORFF00FF;

AA05:=MA(C,5),COLOR0099CC;

五日乖離率:=(C-AA05)/AA05*100;

BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;

速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);

加速度5:EMA((速度5-REF(速度5,1)),3),NODRAW;

AA10:=MA(C,10);

AA20:=MA(C,20);BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;

AA30:=MA(C,30);

三拾日乖離率:=(C-AA30)/AA30*100;

VAR11:=(AA20-AA30)>REF((AA20-AA30),1)

AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);

VAR22:=(AA30-AA20)<REF((AA30-AA20),1) AND AA20<REF(AA20,1) AND

AA30<REF(AA30,1);

BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;

強勢狙擊:=FILTER(BB30>30 AND BB10>45 AND

CROSS(BB05,60),10);

加倉:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND

AA05>REF(AA05,1)  AND 三拾日乖離率>REF(三拾日乖離率,1) AND

AA10>REF(AA10,1)

AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1)  ,10) ;

清倉:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>AA30 OR O>AA30) AND

AA05<REF(AA05,1)  AND 三拾日乖離率<REF(三拾日乖離率,1) AND

AA10<REF(AA10,1),10);

DRAWICON(加倉 ,LOW*0.997,23);

DRAWICON(清倉 ,HIGH*1.005,8);

DRAWICON(強勢狙擊 ,LOW*0.997,7);

AQ1:=REF(V,1);AQ2:=DVOL;AQ3:=AQ2/AQ1;

LNX:=AQ3-REF(AQ3,1);

E1:=REF(C,1);E2:=DCLOSE;E3:=(E2-E1)/E1*100;

QMX:=E3-REF(E3,1);

XG:=CROSS(LNX,500) AND CROSS(QMX,10);

DRAWTEXT(XG=1,L*0.995,""),COLORFFCC88;

DRAWICON(XG=1,L*0.993,25);

{有莊控盤}

VAW1:=EMA(EMA(CLOSE,13),13);

控盤:=(VAW1-REF(VAW1,1))/REF(VAW1,1)*1000;

無莊控盤:=控盤<0;

有莊控盤:=控盤>REF(控盤,1) AND 控盤>0;

{分時價格原碼}

JJ:=DYNAINFO(11);

{波段買賣原碼}

P:=21;S:=8;M1:=3;

財:=(EMA(CLOSE,S)-EMA(CLOSE,P))*50;

神:=EMA(財,M1);

{股價與均線偏離買賣條件}

BTJ1:=(C-JJ)/JJ<-0.03;

BTJ11:=(C-JJ)/JJ<-0.03;

BTJ12:=LAST(JJ>=REF(JJ,1),5,1) AND (C-JJ)/JJ<0.005;

STJ1:=(C-JJ)/JJ>0.005;

{控盤買賣條件}

STJ01:=控盤<REF(控盤,1) AND 控盤>0.5;

STJ02:=控盤>0;

BTJ2:=控盤>REF(控盤,1) AND 控盤<-0.2;

BTJ22:=控盤>REF(控盤,1) AND 控盤<0 ;

{波段買賣條件}

BTJ3:=CROSS(財,神) AND 財<-0.3;

BTJ32:=CROSS(財,神) AND 財<-0.1;

STJ31:=CROSS(神,財);

STJ32:=CROSS(神,財) AND 財>1.618;

{以下為信號};

BTJ81:=FILTER(BTJ1 AND BTJ2 AND BTJ3,13);

BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13);

BTJ82:=FILTER(BTJ12 AND BTJ22 AND BTJ32,13);

STJ81:=FILTER(STJ1 AND STJ01 AND STJ31,13);

STJ82:=FILTER(STJ02 AND STJ32 ,13);

STJ83:=STJ81 AND STJ82;

DRAWTEXT(STJ83,H*1.002,"↓莊出"),COLORGREEN;

DRAWICON(STJ83,H+0.003,24);

莊:= BTJ11 AND BTJ2 AND BTJ3;

有莊:=FILTER(莊,30);

DRAWTEXT(有莊,L-0.0011,"↖莊進"),COLORYELLOW;

DRAWICON(有莊,L*0.999,38);

{牛熊軌道上抓啟爆點 適合抓爆漲股}

AHC1:=CLOSE*VOL;

AHC22:=EMA((EXPMA(AHC1,27)/EXPMA(VOL,27)+EXPMA(AHC1,54)/EXPMA(VOL,54)+EXPMA(AHC1,108)/EXPMA(VOL,108)+EXPMA(AHC1,316)/EXPMA(VOL,316))/4,34);

上軌:=1.06*AHC22;

下軌:=AHC22*0.94;

ZT:=REF(C,1)*1.1-C<0.01 AND H=C;

啟爆:=CROSS(C,上軌) OR CROSS(C,下軌) AND ZT;

DRAWTEXT(啟爆,L,"↖啟爆"),COLORCYAN;

{止損&突破}

止損:=REF(HHV(H,13),1)*0.95,COLORGRAY,DOTLINE;

STICKLINE(CURRBARSCOUNT=1,止損,止損,40,-1),COLORGREEN;

DRAWTEXT(CURRBARSCOUNT=1,止損*0.995,"破止損"),COLORFFFF00;

MAA10:=MA(CLOSE,10),COLORYELLOW,LINETHICK0;

MAA54:=MA(CLOSE,54),COLORFFCCCC,LINETHICK0;

PL1:=(((CLOSE - MAA54) / MAA54) < 0.1);PL2:=(((CLOSE - MAA10) / MAA10) < 0.3);

偏離率:=(((PL1 = 1) AND (PL2 = 1)) * 0.2);

突破加倉:=((((偏離率 = 0) AND (REF(偏離率,1) = 0.2)) AND (REF((COUNT((偏離率 = 0.2),10) = 10),1) = 1)) * 1);

DRAWTEXT(突破加倉,L,"----------突破加倉"),COLORFFFFFF;

免責聲明:本文僅代表文章作者的個人觀點,與本站無關。其原創性、真實性以及文中陳述文字和內容未經本站證實,對本文以及其中全部或者部分內容文字的真實性、完整性和原創性本站不作任何保證或承諾,請讀者僅作參考,并自行核實相關內容。

//www.bygkuu.com.cn/style/images/nopic.gif
我要收藏
贊一個
踩一下
分享到
?
分享
評論
祖拉的世界